Clever Badges Error
Incident Report for Yu Ming Charter School
Resolved
This issue has been resolved. Clever successfully resolved this issue at 9:48 am EST and Badges should be working on all supported browsers.

If you encounter any additional issues, please contact Clever Support through our Help Center: support.clever.com
Posted 14 days ago. Oct 16, 2020 - 07:05 PDT
Clever is experiencing an issue that is causing Badges to hit an error on various browsers. We’re investigating the issue and will provide regular status updates.
Posted 14 days ago. Oct 16, 2020 - 06:23 PDT
Posted Oct 16, 2020 - 06:23 PDT