Issue inviting new admins into the Spiceworks Cloud Help Desk
Incident Report for Yu Ming Charter School
Resolved
This incident has been resolved.
Posted Nov 04, 2020 - 14:43 PST
Monitoring
Monitoring - We have pushed a change live that we feel will resolve this issue. Testing, so far, confirms this. We will continue to monitor the situation to ensure it is resolved, though.
Nov 4, 15:19 CST
Posted Nov 04, 2020 - 13:20 PST
Investigating
We are currently investigating an issue where new admins cannot be invited into the Spiceworks Cloud Help Desk.
Posted Nov 04, 2020 - 11:16 PST